Eurofiber connectivity issues have been resolved. According to Eurofiber, the probable cause is a power outage in the Nikhef datacenter in Amsterdam. Some of their equipment is damaged and they are in the process of replacing the faulty components. There is no expected customer impact during the replacement process. Therefore, we will close this incident too.
Posted Nov 17, 2025 - 11:36 CET
Monitoring
We see Odido 4G and 5G services recovering. Currently, there is no significant impact on 4G and 5G connectivity, but because Eurofiber has not yet formally resolved their nationwide incident, we will keep the incident open for the time being.
Posted Nov 17, 2025 - 11:14 CET
Identified
Odido is currently experiencing nationwide connectivity issues on their 4G and 5G networks. This issue might be related to the current Eurofiber incident because Odido is partly relying on Eurofiber for national data transport.
As a result, 4G and 5G services provided by Art Of Automation may also experience reduced performance and/or availability, since Art Of Automation operates as an MVNO on the Odido network.
Posted Nov 17, 2025 - 10:17 CET
This incident affected: Third-party access infrastructure (Third-party 4G and 5G access infrastructure).