Eurofiber Wholesale ethernet services incident

Incident Report for Art Of Automation

Resolved

Eurofiber connectivity issues have been resolved. According to Eurofiber, the probable cause is a power outage in the Nikhef datacenter in Amsterdam. Some of their equipment is damaged and they are in the process of replacing the faulty components. There is no expected customer impact during the replacement process. Therefore, we will close this incident.
Posted Nov 17, 2025 - 11:35 CET

Update

We see services recovering but according to Eurofiber, the root cause of this nation wide outage is still unclear.
Posted Nov 17, 2025 - 11:06 CET

Identified

Eurofiber is currently experiencing nationwide connectivity issues on their fiber network. Customers utilizing fiber infrastructure from Eurofiber may encounter reduced performance and/or availability.
Posted Nov 17, 2025 - 10:07 CET
This incident affected: Third-party access infrastructure (Third-party fiber access infrastructure).