Eurofiber connections have been stable for the last 30 minutes. We will close this incident.
Posted Nov 18, 2025 - 01:45 CET
Monitoring
According to Eurofiber, there are issues with the planned emergency maintenance, which was scheduled after yesterday's outage. This maintenance work was not expected to have any impact. Unfortunately, that is not the case.
We have seen services recovering since 01:00 CET. Currently, all Eurofiber connections are back online. However, we have not yet received confirmation from Eurofiber that the issue has been fully resolved.
Posted Nov 18, 2025 - 01:15 CET
Identified
Eurofiber is currently experiencing connectivity issues on their fiber network. Customers utilizing fiber infrastructure from Eurofiber may encounter reduced performance and/or availability.
Posted Nov 18, 2025 - 00:07 CET
This incident affected: Third-party access infrastructure (Third-party fiber access infrastructure).